Outage (all hosted services)
Incident Report for Sol1
Resolved
The incident has been resolved.
Posted Mar 17, 2023 - 06:22 UTC
Investigating
Investigating
Posted Mar 17, 2023 - 06:12 UTC
This incident affected: DNS, Zimbra Mail, Mail, Web Hosting, Managed Backups, Spam Filtering, Hardware Colocation, and Virtual Machine Hosting.